How to send emails from a shared mailbox in D365FO

We are trying to set up additional sender email accounts in Docentric for one of our customers. The goal is to send purchase order confirmations from a general info e-mail account instead of the user’s e-mail account. We are a bit blocked in our setup at the moment and would like to find out if the scenario we are considering can be used in this case.

There are different users who create purchase orders in D365, but all purchase order confirmations should be sent from the general info@example.com account (a shared mailbox address) instead of the user who creates the confirmation. The info-account is a shared 365 account that has no login credentials to log in. This means that we cannot specify the username and password in the emailing parameters as required.

image

We also tried to add the accounts in the Docentric parameters in the form setup, and this results in a mail sent from the info-account as expected, but upon replying to it we noticed that it is still sent to the default user’s email account.

Is there a possibility to use your solution to send e-mails from the shared 365 account even if we do not have a password to log in?

You should use the credentials of a user who has the permissions and access to this shared mailbox that you are trying to send the e-mail with. In other words, you should set a User name and Password of an account that is allowed to send e-mail (e.g. from Outlook) from this shared mailbox .

Here is an example of a shared mailbox (webinars@docentric.com) that I can use to send the emails from D365FO.

image

You should, of course, set a different Sender email and Email sender display name in your case - the way I understand you the general company email account should be used?

You can then try to send a test e-mail if you follow these steps:

image

At this point it is only important that the email is sent successfully and you receive it. We will focus on the value of the From field in the next step.

Set the Email print destination for a report of your choice and use the shared mailbox address in the From field. To check whether the From field is resolved as expected when you run the report, enable also either the Preview before print or Open email before sending option.

When the report is generated, you will have the option to download the email. We can now check the Email sender display name (WEBinars) and Sender email (webinars@docentric.com) values in the downloaded file:

But, before further testing of the outgoing emails, please disable the option to Open email before sending:

Important : Do not try to actually send the downloaded e-mail file (.eml) from Outlook. I will not go into detail, but we have already encountered some problems related to the way Outlook/Exchange handles such generated emails. Just print the report again and check whether you get it with a From field resolved as expected. We recommend that you test the behaviour for an external e-mail address as well.

Please let me know if this helps.

Thank you for your response.

I do not have the field Sender email available in the additional email sender accounts table. Is this because we are using the Free version of Docentric?

It seems that you are not using the latest version of Docentric. May I ask which version you are currently using?

Docentric Free Edition uses the same advanced email parameters as Full Edition. I recommend you upgrade as soon as possible - you can watch a short video introducing the latest features we have added.

Nonetheless, we can still use a workaround to achieve your emailing scenario. You need to set the default sending account with the permissions to send emails on behalf of the shared mailbox in Microsoft 365 Admin Center. In other words, the default sending account should be a member of the shared mailbox.

You will then set it as the default sending account, while the shared email account should be deleted from the additional email sender account table.

Batch email provider

You have the option to set either Exchange (supposedly no other settings will be needed, but you should check this with your network administrator):

… or SMTP, where the email from the SMTP settings should have the access to the shared mailbox:

If you now head to Print destination settings and simply enter the shared mailbox account in the From field, an email should generate which you can first download as EML (Open before sending) in order to check the From address, then try to send it directly from D365FO without downloading it.

Please let me know if this has worked or if you need further assistance.

Thank you for your reply. I tried to set it up like you indicated in your mail but the mail is not correct:

00.jpeg

When I do a reply it is sent to my personal email and not to ‘infotest@company.com’

I did the following:

01.jpeg

02.jpeg

03.jpeg

Am I doing something wrong? The info mail address is a shared account of the email account I entered as an Additional email sender account from the first screenshot.

Maybe the problem is that you are trying to send email on behalf of the info email address, but perhaps you are not authorized to do so? Please try to find a user of this company who has the permissions and run the same tests as we previously suggested with his credentials.

I tested this with a user account and now I have the following result:

04

I have no access to the shared info mailbox so I asked the customer to check if a reply to the e-mail is sent to info.

I think that we are on the right path to the final success if I am not mistaken. Now you have the following options to check:

  • set to use Exhange email provider instead of SMTP - it should work as expected;
  • check the value of the Email sender display name if you intend to use SMTP - I believe you are using the @CURRENT_EMAIL@ placeholder and if so, just delete it.

Please let me know if this helped or we can schedule another call and help you troubleshoot further.

Yes, deleting the @CURRENT_EMAIL@ placeholder did the trick!

Thank you!!!
:grinning: :star_struck: