Free version - Email token/redirection

Hi Supporters :slight_smile:

  • I am using Docentric Free version - 3.4.3.1

  • Have customised a Docentric SSRS replica for the Vendor payment advice

  • Under EMAIL SETTINGS - setup Email token and printing redirect to to another email address if TO FIELD IS EMPTY DUE TO UNRESOLVED TOKENS

However when I try to test this - I have a Vendor with a missing email address…it errors when I try to email, instead of just sending to the Redirect email address.

Any ideas?

Regards
James

Hi James,

on the image you posted, I could see that the email was transferred to Batch email sending status.
Could you please check if the email is already there waiting to be processed?

The “To field in not specified” message is not an error, just a warning that this vendor does not have an email address.
There are two other errors, but we can not see the error message on the image.
Could you send us details about the error message?

Good morning Amir

  • No email created, that was the first thing I checked :slight_smile:. It creates only 1 email, for the 2nd vendor that actually has an email address. The first vendor doesn’t (on purpose so I could test the functionality)

  • As I set SHOW WARNING MESSAGE to Never, I would suggest that this is actually an error, not a warning.

Regards
James

Hi Amir,

I am wondering if my Developer has actually done the Development using the SSRS replica incorrectly, might this be causing the issue?

I say this because on the 1 email that did get produced, the Report specific placeholders don’t have information in them.

Regards

Hi Amir,

6th time lucky. No idea why…but now working.

Maybe trying the same thing 6 times fixed it…lol

Regards
James

Hi James,

Thank you for keeping us updated on this matter.
It’s good to hear that everything is now working as expected.

However, there must be some reason why there were issues before and if the issue occurs again, please contact Docentric support so we will look into it.