Cannot generate DDSP file for a report?

Yesterday I designed a check based on your Youtube video and it worked perfectly. Today I had to do the design of a promissory note, but I cannot generate the ddsp file when running the standard report. I see that there is no Replica for this report: is there any way to modify this report with Docentric? Could you tell me how?

Thank you very much!

You can use Docentric to create a template for virtually any SSRS report in D365FO.

If the report is not yet included among the Docentric replicas, you have to register it in Docentric AX Report table first. Next, run this report and select Generate DS print destination, which will create a DDSP file. The file will download in your browser when you execute the report.

Please read the following article, which explains the whole process:
https://ax.docentric.com/d365-how-to-manuals/d365-docentric-ssrs-reports/d365-how-to-improve-ssrs-report-design/

Hi, I followed the instructions in the link that you gave me: I registered this report in the Docentric report setup and enabled the Generate DDSP when report runs flag.

But when I run the report, I get the Standard report design and no DDSP file is generated. I can’t see the print destination either and I don’t know how to do it.

Thank you for your help!

This may not solve the problem, but we first have to make sure which report is actually executed. The following setting to Discover report technical name may come handy in cases like yours.

Go to User options > Account and enable the feature:

Upon printing a report you will now receive the information which report is actually being used in the info log:

Please check that the report you are printing is the same as the report you have registered in Report table and set to generate the DDSP for.

I did this and yes, it is the same report:

Hi, could you please check the status of these two flags for this report?


Both of them should be enabled.

The other possible reason why you wouldn’t get a DDSP file to download when you run the report might be related to a pop-up blocker in your browser. Could you check this too?

Please let me know.

1 Like

Hi, I was finally able to get the DDSP file: it was because of the two flags that you mentioned. Thank you for all your help, I will remember this for the next time!